Hướng dẫn nâng cấp PHP 7.1 cho hosting sử dụng cPanel

Hướng dẫn nâng cấp PHP 7.1 cho dịch vụ WordPress Hosting của Công ty TNHH Phần mềm Oneday.

Trong một bài viết trước đây, tôi đã từng hướng dẫn cho các bạn cách nâng cấp lên PHP 7.0 giúp cả thiện hiệu năng cho blog/ website WordPress rồi phải không nào? Tuy nhiên, vừa qua, phiên bản PHP 7.1.0 đã chính thức được trình làng với nhiều cải tiến cũng như tính năng mới, hứa hẹn mang lại một trải nghiệm còn tuyệt vời hơn. Một số nhà cung cấp hosting đã nhanh chóng tích hợp phiên bản PHP này vào trong cPanel của họ, trong đó có HawkHost – đối tác cung cấp hạ tầng cho dịch vụ WordPress Hosting của Công ty TNHH Phần mềm Oneday.

Và đó cũng chính là nguyên nhân khiến tôi viết bài này: hướng dẫn các khách hàng đang sử dụng dịch vụ WordPress Hosting của Công ty TNHH Phần mềm Oneday tự nâng cấp lên phiên bản PHP 7.1 (nếu có nhu cầu). Đây là quyền lợi dành riêng cho khách hàng của chúng tôi nên mong các bạn khác hết sức thông cảm.

Mặc định các gói hosting do Công ty TNHH Phần mềm Oneday cung cấp cho khách hàng đều đang chạy trên phiên bản PHP 7.0.13.

Hướng dẫn nâng cấp PHP 7.1 cho hosting chạy WordPress

1. Đầu tiên, các bạn cần liên hệ với chúng tôi qua biểu mẫu dưới đây để nhận file hướng dẫn thiết lập module cho PHP 7.1. Những thiết lập này là tốt nhất đối với các blog/ website sử dụng mã nguồn WordPress.

2. Tiếp theo, truy cập vào cPanel, tìm mục Select PHP Version và click vào đó.

3. Lựa chọn phiên bản 7.1 và click vào nút Set as current.

Dòng chữ Current PHP version chuyển sang 7.1 là được.

4. Thiết lập các module theo file hướng dẫn số 1 mà bạn nhận được ở bước 1. Sau khi thiết lập xong, click vào nút Save để lưu lại.

5. Click vào mục Switch To PHP Options ở góc trên bên phải của bảng thiết lập module.

6. Thiết lập các module theo file hướng dẫn số 2 mà bạn nhận được ở bước 1. Sau khi thiết lập xong, click vào nút Save để lưu lại.

7. Truy cập blog/ website của bạn và kiểm tra xem các tính năng đã hoạt động bình thường hay chưa. Nếu rồi thì có nghĩa là các bạn đã nâng cấp PHP 7.1 thành công.

Các phiên bản PHP từ 7.0 trở lên không tương thích với các plugin như SEO Auto Links, Memcached Object Cache… Nếu các bạn đang sử dụng các plugin này thì vui lòng gỡ bỏ trước khi nâng cấp để tránh bị lỗi.

Bạn đang sử dụng phiên bản PHP nào cho blog/ website WordPress của mình? Bạn đã nâng cấp PHP 7.1 chưa? Hãy chia sẻ với chúng tôi quan điểm và ý kiến của bạn trong khung bình luận bên dưới.